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All offices use a variety of internal and external forms.    In spite of this the requirement for 
business forms has not been well catered for in the past by computers.    There have been 
very few programs specifically designed for forms; those manufacturers who have tried to 
provide a solution to the forms problem have done it by incorporating limited form filling 
capabilities into their databases or word processors.    FastForms is much more advanced 
than this because it has been specifically designed with business forms in mind. It is also 
possible to incorporate information from the database into a form as we shall see later.    The
three applications in FastForms are:-

Form DesignFor designing business forms, which can then be printed on your computer 
printer.    There is also a large library of ready made business forms supplied.

Forms Entry For filling in business forms, either those created with the forms designer or 
ones which are pre-printed.

Database For maintaining form data, especially computerised contact lists.    You decide 
what information you want to keep on each record and lists as long as 4 billion records can 
be created.    You can then print labels, reports and forms for the contacts on your database.  
To help you with mailings, facilities like duplicates detection, random sampling and logging 
of mailings are included.



Installing The Software

The files on the master CD and program diskettes are stored in a compressed format so you 
must use the procedure described here to install them onto your hard disk. You will be asked
which directory you want to put the software in.    Normally this will be a directory called 
topforms and we recommend that if you don't understand paths and directories you accept 
this choice of directory.

1 Put Disk 1 into the diskette drive or put the CD in the CD drive.

2 In Win 3.1 pull down the Program Manager File menu and choose Run.    In Win 95 run is 
on the Start menu.

3 Assuming you have put disk 1 into diskette drive A: type a:\setup.    (If you have used 
drive B: type b:\setup).    CD drives are usually d:\setup.    Press Enter or OK and the 
installation will begin.

4 Follow the on-screen prompts and instructions.



Screen Layout

The screen layout in the form designer is illustrated below:-



Menus

Commands on the menu bar lead to a further drop down menu:-

 

Selecting A Menu Bar Command is achieved by pressing Alt and holding it 
down whilst you press the underlined letter of the command, e.g. Alt F for File.        
Alternatively use the mouse.

Selecting A Drop Down Menu Command just press the underlined letter of 
the command you want (normally the first letter).    Alternatively you can move the highlight 
bar down to the command you want using  and 

 then press the 
 or Enter key. Alternatively use the mouse. 

Shortcut Commands Any command on a menu which has a keystroke shortcut will 
have that keystroke displayed next to it on the menu, e.g.    Ctrl F4 for Close Window.

Commands Followed By ... These commands lead on to dialog boxes, which are 
described below.

Leaving A Menu To leave a menu without selecting any command press Esc until you 
get back to the document or simply click on the document.



Using The TopLevel Menu

When you start FastForms it will display the TopLevel menu which is shown below.

 

Each of the applications has its own pushbutton.    To start up one of the applications you 
push the appropriate button.

Beneath the picture for each application is a list of the work you are currently doing.    When 
you first start FastForms all these lists are blank as shown above.

Each piece of open work is put into a "window".    The TopLevel menu allows you to see at a 
glance what windows you have open that is which things you are working on at the moment.

When you have finished a piece of work you close the window it was in.    Normally you will 
save the work first as described under Saving work into files on disk, andFile and Paths for 
Work on Disk

To Start A New Window Press the applications button by clicking it with the mouse or 
moving onto the name beneath it and pressing Enter.    (Alternatively you can press the New 
Window button).    This will open a new window.    You can then retrieve whichever piece of 
work you want into the window by opening the file in which it was saved, or start creating a 
new piece of work.

To Switch To A Different Window Once you have started a few different pieces of 
work each one will be listed on the TopLevel menu.    You can move to the one you want with 
the mouse and arrow keys and press Enter or double click to select it.    (Alternatively you 



can press the Select Window button).

To Close A Window Move across the lists onto the window you want to close and press the 
Close Window button.

To Close FastForms Press the Exit button.    This will take you back to Windows.    All 
your open windows will be closed.

Settings / Workgroup These are described separately further on.



Keyboard And Mouse Equivalents

Selecting a command or object is normally achieved with the mouse by moving the 
mouse pointer  onto it then clicking on it.    Some mouse actions require a double click - 
two clicks in quick succession.

The keyboard equivalent to select a command or object is to move onto it with  
 
 
 or sometimes 
 and Shift 
 then press a key normally either 
 or Enter.    In some cases the 
 or Enter key completes the current action entirely (e.g. in dialog boxes it OK's and 

dismisses the entire dialog box) so a different key, normally the spacebar; is used to make a 
selection.

Dragging is used to select certain things, such as part of a form, and also to move 
certain things e.g. a box in the forms designer.    To drag with the mouse you hold the left 
mouse button down as you move the mouse in the direction you want to drag. To drag with 
the keyboard you hold down the Left Shift key and press one of the movement keys such as

 
 
 and 
.



Disk Files - Saving And Reopening Your Work

You will want to save most of the work that you create in the computer.    This will allow you 
to reopen any piece of work subsequently, even though your computer has been switched 
off in the meantime.    The hard disk is used to store your work for later retrieval, since 
information on the hard disk is not lost when the computer is switched off.

Generally work is not saved automatically for you.    Instead it is up to you to decide what 
you want to save, after all you may not want to keep every form you design or fill in.    You 
also give a name to each piece of work when you save it.    When you want to reopen that 
piece of work you tell FastForms to open the work for you, giving it the name you originally 
used to save the work.

The rule that work is not saved automatically for you is true for forms and their contents.    
But for databases, records on the database are saved as you work so there is no Save 
command on the database menus.    However it is important to Exit FastForms (using the Exit
button on the TopLevel menu) before you switch off your PC if you have been working on a 
database.    This will ensure that the database index files are properly closed.

The database has no Save command since it saves records as you work and form entry 
offers Save Contents rather than Save because it fills in and prints forms already saved in 
forms designer.
The File menu has commands for transferring work to and from disk.    All the commands 
affect the piece of work in the current window only (this is normally the only piece of work 
displayed on the screen).    

New will clear the window ready for a new piece of work. 

Open retrieves work you have already saved on the disk.

Save / Save Contents will save a piece of work onto the disk so that you can retrieve 
it again later.    If it is a new piece of work you will be asked to give the name and path or 
folder for it.

Save As / Save Contents As can be used to save a copy of a piece of work with a new
name.    You will be asked to give the name and path you want to use for the copy.    After a 
Save As the work displayed on the screen will be the one with the new name and path.

Close will close the current window without saving your work. 



File And Paths or Folders For Work On Disk

Windows 3.x:-
Windows 95:-

Your work is kept in files on the disk.    Generally there is one file for each piece of work, 
although a database uses several files.    File names are a part of DOS and will be described 
in the manuals which came with your computer if you want to find out about them in detail.  

In Windows 3.1 file names are up to 8 letters and numbers optionally followed by an 
extension of up to 3 letters and numbers which indicates the file type. You cannot leave 
spaces in the names and most punctuation characters are disallowed; we recommend that 
you use a hyphen if you want to put punctuation in a file name.    

In Windows 95 both the name and the extension may be longer and spaces can be used too.

Examples of file names could be:-

credapp.tfm a form, indicated by the extension tfm, called credapp.

credit application.tfm can be used in Windows 95.

johncred.tff the filled in contents of a form, indicated by the extension tff, perhaps 
the credit application form as sent to a customer called John.

prospect.tdb a database, indicated by the extension tdb, called prospect.    This has 
some associated files e.g. prospect.idx and prospect.lab..

The path for a file indicates which disk or diskette drive and which disk directory or folder 
(the term "directory" in Win 3.x became "folder" in Win 95).    Paths and folders are a part of 
DOS which will be fully explained in the manuals which came with your computer.    They 
enable you to split your hard disk up into separate named areas called directories/folders 
storing your work logically.    Without this you might have 50,000 files stored on the disk 
which would be presented to you in one long list making it extremely difficult to find your 
work.

If you don't understand paths yet there is no need to rush to read up on them because 
FastForms will by default reserve a separate area (directory or folder) on the hard disk called
fastform for itself and within that further separate directories/folders for each type of work 
you do.      These separate directories/folders are called:-

\fastform\forms (forms folder within fastform folder) used for forms.

\fastform\database used for databases.

\fastform\pictures source of pictures.

When you choose Open, Save for the first time or Save As you will be prompted to fill in the 
file name and path.



Windows 3.x:-

 

File Name is the name of the file. You can type in the 8 character name here 
directly if you want. You normally would do this if you were saving a file for the first time
since it is up to you to invent a name for it.    When you type in the name you can either 
include or exclude the 3 character extension at the end.

If you include the extension, e.g. jenny.fax this extension will overrule any extension 
shown in the List Files Of Type box below.    If you leave the extension off, e.g. jenny then
the extension shown here will automatically be added for you, e.g. jenny.tff.    If you 
want to force a file name to have no extension type in a full stop at the end of the 
name, e.g. jenny..

Files shows a list of files for you to choose from.

List Files Of Type shows the extension which is currently being used to control 
which files show on the Files list.    Pull this down if you need to change the type.    This is
useful for exchanging work with other applications e.g. to open a FormTool form.

Directories (Win 3.x only) allows you to set the directory path. You can move up 
and down amongst the directories by selecting them from the list displayed here, which 
will always show all the directories below the current path.    So to move to the root 
directory on the current drive select the top entry - f:\ here.

Drives (Win 3.x only) allows you to set the disk or diskette drive. If you want 
to use the diskette drive select a: or b: from here.    If you have one diskette drive it will 
normally be a:.

Set Default Path (Win 3.x only) If you have used Drives and Directories to alter 
the path of the piece of work you are about to open and plan to continue to use this 



path for other pieces of work then choose this to cause FastForms to remember the path
you have set up until you Exit from it.

Delete (Win 3.x only) will delete the piece of work currently named in the File 
Name box, from the disk.    This is final you are throwing away the work for good, so 
make sure that you really have finished with it!

Library (Win 3.x only) will swap to the directory of forms in the library supplied with 
the software, when opening forms.

Filled Forms (Win 3.x only) will swap to show filled forms (provided you did not use 
a different file extension from tff) when using Open in the Form Entry application.    The 
Win 95 equivalent is to use Files of Type    and choose Form Contents.

There are other occasions when you need to choose a file from a list of files on disk.    When 
this happens you will be offered similar choices to those outlined above.



Windows 95:-

File Name is the name of the file. You can type in the 8 character name here 
directly if you want. You normally would do this if you were saving a file for the first time 
since it is up to you to invent a name for it.    When you type in the name you can either 
include or exclude the 3 character extension at the end.

If you include the extension, e.g. jenny.fax this extension will overrule any extension 
shown in the List Files Of Type box below.    If you leave the extension off, e.g. jenny then 
the extension shown here will automatically be added for you, e.g. jenny.tff.    If you want
to force a file name to have no extension type in a full stop at the end of the name, e.g. 
jenny..

Files shows a list of files for you to choose from.    For Windows 95 you can also see 
any folders in this folder listed here.

List Files Of Type shows the extension which is currently being used to control 
which files show on the Files list.    Pull this down if you need to change the type.    This is 
useful for exchanging work with other applications e.g. to open a FormTool form.

Look in (Win 95 only) pulls down a list of folders and drives.

There are other occasions when you need to choose a file from a list of files on disk.    When 
this happens you will be offered similar choices to those outlined above.



Layout Files

There is one other type of file you will want to save explicitly and these are layout files.    
Layout files hold the formatting information for your work; the margins and print routing for 
a form.    Neither the forms design nor its contents are saved in the layout.

.fly form layout



The Clipboard

The clipboard is an area which can be used to copy information from one Windows 
application to another.    Copying information via the clipboard usually works even if the 
applications are two completely separate ones from different software manufacturers.
The three commands associated with the clipboard are Cut, Copy and Paste found on the 
Edit menu. 

They work on the marked block. The marked block is part of a piece of work normally 
marked either by dragging the mouse over it or by pressing and holding down the Left Shift 
key whilst you move the cursor over the block using any of the available movement keys.    
For example Shift with , 

, 
 and 
 will mark an area in most applications.

Cut Deletes the marked area from the form and transfers a copy of it onto the clipboard.   
Anything else which was already on the clipboard will be lost.

Copy Transfers a copy of the marked block to the clipboard.    Again anything else which 
was already on the clipboard will be lost.

Paste Copies information from the clipboard into your work.    Notice that Paste will be 
unavailable (indicated by grey writing) if there is nothing on the clipboard which can be 
copied into your work. 



System Wide Features

System Settings
Workgroup Items & Autoincrement Numbers
Creating Standard Phrases
Swiftkeytm Foreign Character Entry



System Settings

The settings box can be called from the TopLevel menu.    The choices you make here will be 
remembered until you subsequently come back to change them.



Workgroup Items & Autoincrement Numbers

Workgroup items are useful when you have data which you wish to share amongst several 
users on a network, or simply to be remembered between successive uses of the form entry 
application to fill in a form.

It is particularly useful for invoice numbers, because the system will remember what number
you were on last time you created an invoice.

Other information such as the company name, can also be set up as workgroup data.    
These can then be incorporated into forms and will alter automatically in the future if you 
subsequently alter their value in the Workgroup data.

You can reach the Workgroup data either by pressing the Workgroup button on the Toplevel 
menu or from the Options menu.

Name This is the name you choose to give the item.    This name will be available to 
you as part of the field style when you draw fields on forms.

Type This is the type of data it will hold.

Value This is the current value of the item.    You begin by giving the initial value and
can subsequently return to change this.

Auto Inc Checking this causes the system to automatically increment numeric items.



Creating Standard Phrases

Edit Phrase calls the phrases dialog:-

Each of Edit, Copy and New leads onto the dialog box below, which allows you to set up the 
phrase.

Name This appears on the Phrases list when Insert Phrase is chosen.

Key his is the shortcut key combination.    You must enter a Key and select 
at least either With Ctrl or With Alt 



Swiftkeytm Foreign Character Entry

French à Ç ç É é è ê ù « »
German Ä ä ß Ö ö Ü ü ë ï ÿ
Spanish & Dutch Æ æ Å å á í Ñ ñ ¿ ó
Swedish Ä Å ä å É é Ö ö Ü ù
Italian à É é è ì ò ü ¥ ó ú
Various â ê î ô û ¢ ª º ® ©
Currency & Various £ ¢ ¥ $ ¬ · ¡ ¤ § ¯
Greek & Various ß µ Þ þ ¦ ¨ ¸ ´ ' '
Maths ° ¹ ² ³ ¼ ½ ¾ ± × ÷

These are arranged in sets of 10 as shown above.    Each set of 10 can be entered by keying 
Ctrl with the numeric keys along the top of the QWERTY pad.    For example, if you have the 
French set enabled pressing Ctrl 1 will put in à, Ctrl 2 will put in Ç, Ctrl 3 will put in ç and so 
on.    The 1 line help at the bottom of the screen shows which Swiftkey foreign characters are
available.

Changing Character Sets is achieved by pressing the two arrows on the right hand end of 
the help line (keyboard equivalents are Ctrl F1 and Ctrl F2) which cycle through the available
character sets.    As you do this the 1 line help will change to show you which set of 
characters is currently enabled.



Software Support 

The software has been designed to be especially easy to learn and use. However; often 5 
minutes of personal help can save a lot of frustration.      We provide a telephone support 
service and better still it is FREE for an initial period, as shown on your registration card - 
you only pay B.T.'s call charges.

To qualify for support please complete and return the registration card included in this pack. 
The support hotline number is printed on the back of the manual and it is normally available 
9 - 1 and 2 - 5 Monday to Friday, except on bank holidays and during the Christmas break 
when we are closed.

Please have the following ready if you need to call:-

- Your name and company name.
- Your registration number.
- This manual.
- A description of the problem.
- Have the computer switched on ready to use during your enquiry.

Please note that free telephone support is intended for the individual named on the card as 
the regular user of the PC on which the software is installed.    We reserve the right to limit 
support to this person in certain circumstances - for example if large numbers of temps are 
employed sharing the same PC!

After your free telephone support expires you can buy an extended software maintenance 
contract.    Details on the costs and service options available will be sent to you 
automatically before your free support expires provided we receive your registration card.



Designing Forms

To Create A New Form
Form Size And Margin Settings
Placing Lines And Boxes On The Form
Changing The Line Style
Placing Text On The Form
Choosing Text Alignment
Altering The Font
Altering Character Style
Placing Fields, Checkboxes And Listboxes
Drawing An Entry Field
Line Types, Borders & Shadows
Shading
Filling, Validation & Linking
Specifying The Field Input Order
Setting Up Calculations On Forms
Including Pictures In Forms
Moving, Copying And Deleting
Changing The Size Of Objects
Linking Fields To Workgroup Items
Making A Form To Use With Pre-Printed Forms
Multi-Page And Multi-Part Forms
Saving And Reusing Form Layouts
Choosing The Printer And Printer Paper Bins
Previewing And Printing Blank Forms

The objects you can draw on a form include, lines, boxes, entry fields, check boxes, list 
boxes, pictures and text.    You can use different types of shading and vary the appearance of
the lines on a form.    Text can appear in a variety of fonts and sizes, with different styles 
such as bold, italic and red.

A field on a form is used instead of a box when the information on the form is to be filled in 
on the computer instead of being filled in by hand.



To Create A New Form

When you first start the forms designer it will present a screen similar to the one below.    
This is waiting for you to create a new form.    The indicator on the status bar will say BOX 
and the pointer will appear as a crosshair ready for you to drag out a box anywhere on the 
paper.

The mouse pointer may appear as an arrow  to indicate that you can move it and select 
commands or as a crosshair when you are positioning new objects.    When an object has 
been selected and you position the pointer over that object ready to move or copy it the 
pointer changes to a four headed arrow. 

You can move the pointer with the mouse 
or with the four arrow keys  

 
 

Sideways Movement Keys The Home and End keys will immediately alter 
the display to show the left and right hand sides of the form respectively.

Vertical Movement Keys The PgUp and PgDn keys move a screen at a time.    Pressing 
Ctrl PgUp and Ctrl PgDn will move a page at a time. 

Scroll Bars Click the arrows at either end of the vertical or horizontal bars to scroll 
up/down or left/right. Click either side of the scroll bar box to move in larger jumps. Drag the
box along the scroll bar to move to a new position on the page, e.g. halfway along the scroll 
bar for halfway down the page.

RulersThese show you how far away from the margins you are, and allow you to size up 
objects and/or text more easily.

Drawing Toolbar This displays the different types of objects you can draw, e.g. click on 
the box tool to draw a box. These drawing options can also be found under the Tools menu. 
The Drawing Toolbar can be dragged across the screen using the bar at the top of it.



FastForms is ready for you to set the margins, choose your printer and use the different 
types of drawing tools to create your form.

Go To Button The Go To function button is useful for moving from page to page 
(Note: forms are initially 1 page only; use Edit Add Page to add the extra blank pages first):-



Form Size And Margin Settings

The Margins command on the Layout menu is principally concerned with the paper size and 
margins:-

Page Size The drop down list will allow you to choose one of a range of standard 
paper sizes.    If you pick Custom from the list you can enter your own paper size in Width
and Height.

Margins Enter the widths and depths you want using either inches or centimetres 
depending which you have chosen in the System Settings.

Fit to Screen Press these buttons to cause the margins to be set so that the form 
just fits the screen.    This is useful for designing database screen forms.



Placing Lines And Boxes On The Form

Steps:-

Placing a line or a box on the form is very simple, essentially what you do is draw it using 
the mouse pointer.



Steps:-

1 Click the Line or Box button or use Tools Line / Tools Box.

2 The pointer will show as a crosshair with a little box or lines adjacent to it indicating 
whether you have chosen box or line.    Notice the two markers on the ruler indicating 
exactly where the pointer is positioned.

3 Move the crosshair pointer to the start of the line or box then start dragging it in the 
direction you want to grow the box or line.

4 Pull out the crosshair pointer to the end of the line or box and stop dragging it to 
complete the object.    You will not be able to complete the object if the box edges 
intersect with another box illegally.    Move the crosshair to a legal position and click to 
finish drawing the box.

Overlapping Boxes Box edges are prevented from intersecting with one another, 
although boxes can be placed inside each other. When you place one box inside another 
FastForms will ensures that the inner box shading obliterates that of the outer box. This 
makes it very easy for you to draw a number of small white boxes inside a larger shaded box
as shown in the picture.



Aligning Boxes and Lines FastForms uses a grid of 1/20th inch.    You will notice 
that the mouse pointer moves in little steps of this size as you drag out the full extent of a 
box or line.    The grid is provided so that you can easily line things up with the naked eye on 
the screen.    Without this grid it would be extremely difficult to draw two boxes one above 
another which started at exactly the same distance from the left margin.



Changing The Line Style

When you draw a line it will appear in the same style (e.g. colour and thickness) as the last 
line you drew.      The Line Style dialog lets you change its style.

1 Move the pointer onto the line and double click or select it with Enter then press the 
Style function button.    This selects the line and brings up the Line Style dialog box.

2 Choose the style you want for the line 



Placing Text On The Form

1 Select the font you want for the text from the status bar.    You don't have to do this first 
as you can change them later, but it is usually easiest to do this first so that you can see
how much space the text will take, as you create it.

2 Select the character style (bold, italic, word underline, total underline, double underline 
and/or a colour) from the status bar.    You can always change this later if you wish.

3 If the text tool is not already selected choose the Text command    from the Tools menu 
or press the Text function button.

4 Move to the top left the text and start dragging to create a frame for the text.

5 Continue dragging to pull out the pointer to the bottom right corner of the text.    As you 
move one or more lines will appear within the larger text frame. These indicate where 
the text will be positioned. You can tell how many lines of text will fit in the frame in the 
current font.    The top right of the status line also tells you approximately how many 
characters will fit on each line. The character count is approximate because it depends 
what you type - some letters are wider than others.    When the frame reaches the right 
size stop dragging at the bottom right corner.



6 The text cursor is now in the text frame ready for you to type the text.    Remember, 
there is no need to press  at the end of each line since you have automatic word wrap 
within the frame.

7 Finish the text either by pressing Esc or by pressing  on the last line or by doing 
something else e.g. clicking outside the text or giving one of the other commands.



Choosing Text Alignment

You can change the alignment of text in an object.      This is part of the object's style.    To set
the alignment style for a text object, press or click the Style function button, whilst the text 
is selected:-



Altering The Font

You can alter the font used for text in any object, not just text itself.    Fields, list boxes and 
checkboxes all contain text whose font can be set. To alter the font and point size:-

1 If you have already drawn the object then select it in the usual fashion.

2 Now select the font and point size you require.    Press the font button on the status bar (
keystroke Ctrl F) to get the font list.

3 Choose the font and point size you require.

Notice that for list boxes the font in the drop down part of the list box is not affected.



Altering Character Style

The character style can be bold, italic, underline, word underline, double underline and/or 
coloured.    These are selected from the buttons on the status line:-

B bold, key combination Ctrl B.
I italic, key combination Ctrl I.
U total underline, key combination Ctrl U.
W word underline (often called broken underline), key combination Ctrl W.
D double underline, key combination Ctrl D.
· colours button, key combination Ctrl.

The colours button brings up a dialog box which illustrates the colours available (this shows 
as shades of grey on a black and white screen).    Choose the colour you want, remembering 
that you need a colour printer to actually print in colour!



Placing Fields, Checkboxes And Listboxes

A field looks similar to a box. The difference is that fields define the places where 
information will be filled in on the form.

In the job application form shown above, the areas at the top for the candidates name and 
address are set up as fields.    This is because they are to be filled in on the computer screen 
either in Form Entry or by linking the form and fields with a database.    
Other boxes are simply boxes because they will be filled in with a pen by the candidate.    

Notice that baselines in the fields showing where the text will appear are displayed in this 
picture.

The picture illustrates one of the clever features of FastForms.    All the fields and boxes 
which are to be filled in have been drawn as white. When you place one box inside another 
FastForms will ensures that the inner box shading obliterates that of the outer box. This 
happens automatically however many boxes you enclose in one another.

Whether you intend to fill in the form in Form Entry or to fill it in using the Database you 
create your fields in the same way. 





Drawing An Entry Field

Comb Style Entry Fields
Drawing A Check Box
Drawing A Drop Down List
Setting Up The List Choices

1 It is easiest if you first set the font, point size and character style in which you want the 
field contents to appear.    These are set from the status line.

2 Choose the Field tool either from the Tools menu or from the drawing toolbar.

3 Move the pointer to the top left corner of the field and start dragging to pull out the field
box.

4 Now drag the pointer to the bottom right corner of the field.    As you move the pointer 
you will see one or more lines appear within the larger field box.    These indicate where 
text typed into the field will be positioned. They are called baselines.    When the box 
reaches the size you want stop dragging to position the bottom right corner.



Comb Style Entry Fields

A comb can be very useful on an entry field. It forces characters to be entered one per box.   
A typical application for this might be an entry field which is to hold a credit card number.

For this a 16 character long horizontal comb could be used.

1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6

To make    a comb on an entry field:-

1 First draw an entry field as described under Drawing An Entry Field.

2 Now either double click the field or select it then press the Style button to get the Field 
Style dialog.

3 Click on Text within that dialog.

4 Choose the comb options you want.

 

5 When you have set the comb up its teeth will be displayed on the field on the form.    You
can adjust the number of teeth either by selecting the box and dragging it to a new size 
with the handles or by altering the font size.



Drawing A Check Box

1 It is easiest if you first set the font, point size and character style in which you want the 
check box to appear.    These are set from the status line.    The size of the check box is 
automatically adjusted to suit the font height.

2 Choose the Checkbox tool either from the Tools menu or from the drawing toolbar.

3 Move the pointer to the top left corner of the Checkbox and start dragging to pull out 
the outline for the check box and it's accompanying text.

4 Now drag the pointer to the bottom right corner of the outline.    As you move the 
pointer down you will see a line appear within the outline.    This is the baseline where 
you will type the checkbox text and its appearance    indicates that the outline is now 
deep enough for a checkbox in the current font.    

When the outline reaches the size you want stop dragging. When the form is filled in the
entire outline will be the "area of sensitivity" for mouse clicks, even if you put in a much 
shorter text description next to the checkbox.    Outlines appear whilst you are drawing 
the checkbox and you can set form design to Show Checkbox Outlines from the Options 
menu so that the text will continue to be displayed as outlined whilst you finish 
designing the form.

5 Now type in the text you want next to the checkbox finishing by pressing Enter.

6 You can alter the text alignment by selecting the check box and pressing the style 
button.    Text can be left or right of the check box and left or right justified.



Drawing A Drop Down List

1 It is easiest if you first set the font, point size and character style in which you want the 
list box to appear.    These are set from the status line.

2 Choose the Listbox tool either from the Tools menu or from the drawing toolbar.

3 Move the pointer to the top left corner of the field and start dragging to pull out the 
outline of the list box.

4 Now drag the pointer to the position of the bottom right corner of the list box, when it is 
dropped down.    

The font height you have selected governs the size of the list box when not dropped 
down.    You should drag out an outline which is considerably deeper than a single line of
text to allow room for the list to be dropped down.

5 When you stop dragging the list box will be displayed.

6 When you select the list box subsequently you can click the drop down arrow at its right 
end so that it will be displayed showing the outline when dropped down.    This allows 
you to adjust the size of the drop down area using the dragging handles if you wish.



Setting Up The List Choices

After you have drawn your list box you will want to set up the pull down choice list contents.

1 Either double click on the list box or select it then press the Style button to reach the 
Style dialog for lists.

2 You may want to set the type of data in the list box, before putting in the choices list.    If
so use Filling and Linking to do this first.

3 Now press the Values tab to set up the choices list.

 

List Data Give the values for your list here. Make sure you put in data which is 
consistent with the fields type.    For example, if you have chosen a date or number type 
for the list box type under Filling & Linking it does not make sense to use text such as 
"red".

Permit values not in list Set this to allow other values to be typed in when the 
form is filled.    If you uncheck this then only values from the list are permitted.

NOTE Dropped down values are displayed in a plain sans serif font.



Line Types, Borders & Shadows

The style button allows you to set the control the colour and thickness of lines and borders, 
use rounded corners and drop shadows.    Exactly what is available depends whether the 
object is a line, box, entry field, check box or list box.

1 Move the pointer onto the object and double click or select it then press the Style 
button. The style dialog will appear.

2 Choose the style you want for this object.    We have illustrated this for boxes because 
these have the most comprehensive range of choices; for example lines do not have 
shadows or rounded corners.

Auto Shadow is a special option which causes the shadow colour to be automatically 
chosen to show up on the background.    For example dark yellow shadows will be used 
on a yellow background and bark red shadows on a red background.



Shading

The style button allows you to set the shading for boxes, entry fields, check boxes and list 
boxes.    You can also choose a patterned shading.

1 Move the pointer onto the object and double click or select it then press the Style 
button. The style dialog will appear.

2 Choose the style of shading you want for this object.    We have illustrated the dialog for 
boxes..



Filling, Validation & Linking

This applies to entry fields, check boxes and list boxes.

1 Move the pointer onto the object and double click on it or select it then press the Style 
button.

2 Now choose the options you want.

 Name FastForms will name your fields Field_1, Field_2 and so on.      However you 
may find it helpful to give your own meaningful names, e.g. Address, Telephone etc..
To use a Workgroup Items pull down the list and select the one you want.

Type This does not apply to check boxes.    Text, plus a variety of number and date 
formats plus pictures is offered.    The type is useful for validation as data is checked to 
see that it conforms to the type on entry.

Decimal Points This is an option for number types.

Protect Check this to protect fields from being changed.    This is useful for important 
information or for the results of calculations.

Mandatory Check this to force a field to be filled during Form Entry or when linked 
to the Database.

Initial Values and Complex Validations If you want to give an initial value for the 
field you can do this using the Maths tool calculator. More complex validations, such as 
comparisons on the values in fields can be set up using the functions available in the Maths 
tool calculator.    These functions, which are standard PC spreadsheet functions, are 
described in detail in the on-line help.



Specifying The Field Input Order

The normal order of input for fields is to work left to right, top to bottom down each page of 
the form in turn.    However you may well want to use a different order.    For example, if you 
have put the company name and address on the top left of a form and the phone and fax 
numbers next to it on the top right you will want to fill in the name and address completely 
before going on to the phone numbers.

Select Field Filling Order from the Edit menu and you will see a dialog box listing the field 
names.    This is why it is a good idea to use field names even if the form is not for use with a
database, you need the names to specify the input order.    Unnamed fields will have a 
unique name invented for them on this list but obviously if you have a lot of unnamed fields 
the list will be hard to reorder.

Natural Order Restores left to right / top to bottom order.

Move Up / Down To move a field up or down put the highlight bar on the field 
and press this button. 



Mark For Skip / Remove Skip Setting a field as a "Skip To" field is useful when 
you are designing a form with one line of fields repeated down the form such as a 
purchase order.    Although the form may allow room to fill in up to 20 items, most 
purchase orders will only be for one or two items.    In this case, it's a good idea to make 
the Carriage field a "Skip To"    field.    The operator can then fill in an item to be 
purchased on the top line then skip on beyond the remaining order item lines using Shift 
PgDn during Form Entry and Database form filling. Similarly pressing Shift PgUp skips 
back to the previous Skip To field.

When the fields are in the right order press OK to save the new order.    Pressing Cancel will 
abandon the changes to the order you have made.



Setting Up Calculations On Forms

You can set up calculations which include simple arithmetic, any of the spreadsheet 
functions listed in the appendix, references to other fields on the form and references to 
items in a database if there is one linked.    You can also use the calculator to set up an initial
value for the field.

In the illustration the Maths toolbar has been switched on and is currently displaying the 
formula on one of the fields.    This calculation automatically deduces the contents of the 
Amount1 by multiplying Unitprice1 by Quantity1.

You can examine the formula in any field by pushing the Maths button to display the 
calculator then selecting the field.    The calculator will always show the formula in the 
currently selected field.

You can move the calculator toolbar around the screen in the same way as any Windows 
dialog, e.g. by dragging it from its title area or by pressing Alt to pull down the toolbars 
control menu from its top left corner.

To set up or alter a calculation in a field:-



1 Push the Maths button to display the calculator toolbar.

2 Select the field you want.

3 Pull down the calculator tool using the Arrow on its righthand end.

Number pad This can be used to put in numbers and operators as with any 
calculator.    You can also type them directly into the entry line.

Form Fields can be included in the calculation either by typing their name or by 
selecting them.    When the calculator is being used to put in a formula tabbing from field
to field selects them with the keyboard.

Functions can be included by pressing the fn() button which presents a scrolling 
list to choose from.    These can be used to set up validations too. See the on-line help for
a full description of the functions.

Clear Pressing the rubout button clears the calculator entry line.



Including Pictures In Forms

You can insert a picture into a form.    The picture you insert may either have been put onto 
the clipboard by another Windows application or it may be taken from the hard disk.    Most 
applications can save pictures on the disk or on the clipboard in a format which is 
acceptable to FastForms.

To insert a picture from the disk, pull down the Insert menu and choose Picture.    Select the 
picture you want from the list and it will be included in the form.

Once the picture is included in the form you can select it.    It can then be dragged to a new 
position or resized using the dragging handles.    

Format Picture You can use the Style command on the Edit menu or press the Style 
button to alter the appearance of the marked picture.

Cropping This is a % you would like to cut off the edges of the picture.    It is useful for 
removing unwanted areas around the edges of pictures.    If you specify a negative 
cropping e.g. 5% this will add a white area around the picture, which may be useful in 
conjunction with a border.

Absolute Width / Height These are the actual widths and height you want 
for the picture expressed in inches or centimetres depending on your choice of units in 
the system settings.

Percent Width / Height These are the percentage width and height of the 
original size which the picture occupies.    You can choose to scale the picture using 
either these percentages or by setting the actual sizes as described above.

Border Choose the appearance and colour of the border you want.    Use 
negative cropping if you want to separate the border from the the picture.



Moving, Copying And Deleting

Dragging To Move And Copy
Working With Object Groups
Using Edit Commands To Move, Copy And Delete

You can move or copy any object, a line, a box, a picture, a piece of text or any type of field. 
You can also outline a group of objects to be moved or copied. 



Dragging To Move And Copy

1 Select the object by clicking on it once. 

2 An outline box with "handles" (square boxes around the edges) will appear round the 
selected object.

3 To move the object put the pointer over it and start dragging with the left mouse button 
or Left Shift and arrow keys and the outline will move in the direction you are dragging. 

Notice that as you drag it, the outline and crosshair move around to show where the object 
will be.

4 Copying works similarly except that you drag a copy of the object with the right mouse 
button or Right Shift key.

5 When you are happy with the new position stop dragging to put down the object.

6 Notice that the object remains selected even after you have put it down in its new 
position.    So, if you don't like the new position, you can simply pick it up and move it 
again.



Working With Object Groups

You can select a whole group of objects as shown in the illustration below. Once the group is 
selected it can be moved and copied by dragging or using commands from the Edit menu. To
select a group:-

1 Choose the Group tool if it is not already indicated on the status bar.    Press the Group 
function button or select the Group command from the Tools menu.

2 Move the crosshair to the top right of the objects you want to include in the group and 
drag out the outline of the group.    Only objects which are wholly enclosed in the 
group will be incorporated into it.    The individual objects within a group will be outlined 
so you can tell what you have included in the group.

3 To move the group start dragging the object with the left mouse button or Left Shift key 
and the outline will move in the direction you are dragging. 

4 Copying works similarly except that you drag a copy of the group with the right mouse 
button or Right Shift key.

5 When you are happy with the new position stop dragging to put down the group.



6 Notice that the group remains selected even after you have put it down in its new 
position.    So, if you don't like the new position, you can simply pick it up and move it 
again.



Using Edit Commands To Move, Copy And 
Delete

You can use the commands on the Edit menu, in which case they affect the selected object 
or group.    These work via the Windows clipboard.    See the previous explanation of the 
clipboard.

Cut This removes the selected object or group and puts a copy of it onto the clipboard.

Copy This makes a copy of the selected object or group on the clipboard.

Paste This takes a copy of the object or group on the clipboard and puts it onto the form.

Paste Duplicate This copies the object or group from the clipboard onto the form 
making duplicates of any fields instead of making copies of the fields with new names.    
Duplicate fields have the same name and also have the same contents when the form is 
filled, because contents are copied automatically to all a field's duplicates when that field is 
changed.    Duplicate fields are useful for creating multipart forms, where several pages 
contain the same information.

Delete This deletes the selected object.

Undo This retrieves the last object you deleted.

You can also Cut, Copy and Paste text into and out of a text object.

Overlapping boxes and fields The edges of boxes are not allowed to intersect with one
another, although boxes can be placed freely inside one another. Fields cannot overlap one 
another at all, either totally or partially.

Can't put a group    down? Remember that the edges of boxes are not allowed to 
intersect with one another, although boxes can be placed freely inside one another.    
Similarly fields cannot overlap one another at all, either totally or partially.    Move the group 
to another position then click to try and put it down again.



Changing The Size Of Objects

You can enlarge or reduce any objects, lines, boxes, text or fields, after you have created 
them. The procedure for this is similar to drawing the object in the first place.

1 Click on the object to select it. 

2 The outline and "handles" (small black boxes) around the object, indicate that the object
is now selected.    

3 Move the pointer onto the small black box on the side of the outline which you need to 
move to change the size of    the object.

4 When you have the pointer positioned correctly it will change to a double headed arrow 
indicating the two directions in which you can adjust the size.

5 When you start dragging the object the outline will change shape.    Continue to drag 
until the outline of the object is the right size and shape.

Moving instead of changing size? If the entire object moves it is because 
you started dragging when the mouse pointer appeared as a four pointed cross not when it 
appeared as a small double headed arrow.    Drag the object back to its original position (or 
press Esc before you release the object) then start again from step 3 above.

Too Much Text? When you first create a text box you cannot put in more text than the 
box can hold. However if you reduce the size of a text box there may no longer be room to 
display all the text. If this happens you will need to change the text or alter it to a smaller 
font.



Linking Fields To Workgroup Items

1 Draw your field in the normal way then, either double click on the field or select it and 
push the Style button.

2 When you pull down the list of names you will be offered the workgroup items as 
choices. Select the Workgroup Item you want.



Making A Form To Use With Pre-Printed 
Forms

If you want to use FastForms to fill in pre-printed forms, then you can do so provided your 
printer can handle the paper size of the pre-printed form.    There are two things you should 
do.    

Firstly you need to measure up your pre-printed form and make a copy of it with the form 
design application.    Ensure that the paper size and margins match those on the pre-printed 
form and that all the fields are in exactly the same place on the form as the areas you used 
to type into on the pre-printed form.    You can put whatever text you like on the form, 
copying the text already on the printed form and making extra comments and reminders of 
what to put on the form for the typist if you wish.      This text will appear on the screen as 
usual during form entry.    None of the text, boxes or lines you put in the form you design will 
appear on the pre-printed form in the end so you are free to put what you like.    It is only the
fields which will finally be printed.

Secondly, since you only want to print the field contents you select the Print Field Contents 
Only option from the Print Routing box.    This is reached from the Layout menu.

Once you have created the form you can use Form Entry to fill it in or fill it in from the 
database.    When you want to print ensure that the Print Fields Only option is checked.



Multi-Page And Multi-Part Forms

You can create multiple page forms.    There are options to control the pages on the Edit    
menu:-

Add Page Adds another blank page as the last page of the form.

Insert Page Inserts a blank page preceding the current page.

Delete Page Deletes the current page.    Before the page is deleted you will be 
asked to confirm that you really do want to delete it.

The status bar tells you what page you are working on and the vertical scroll bar now 
includes a "page up" icon at the top and a "page down" icon at the bottom. 

The Go To function button also allows you to move instantly to the top and bottom pages of 
the form or to any numbered page.

Multi-Part Forms where the same information appears on several pages can also be 
created.    Use Paste Duplicate from the Edit menu to copy duplicates of a field or group of 
fields from one page to another.    Because the resulting fields are duplicates of each other, 
when any one of them is filled in during Form Entry, all the duplicates on the form are 
updated.



Saving And Reusing Form Layouts
Saving Layouts
Applying An Existing Layout To A Form
Changing An Existing Layout
Basing A New Layout On An Existing Layout
The Default Layout

The form layout includes the settings you have made from the Layout menu; margins, print 
routing (target printer and printer paper bins).    All these settings can be reused in a 
different form without needing to set them all up again.



Saving Layouts

Use the Save Layout command on the Layout menu.    The text, boxes, lines and fields of the
form are NOT saved when you do this.

When you save a layout it is stored on the computers hard disk along with your forms and 
other work so that you can retrieve it later.    So you are asked to give it a File Name and 
optionally to choose a path/folder as described under File and Paths or Folders.    The 
extension for form layout files is normally .FLY; and this is added automatically to the name 
you give.

For example you might have layouts called, A4LASER, DOTMATRX and SALESDB in your 
organisation.    When new forms are created you can reuse these same layouts.    This not 
only helps the individual to achieve a consistent format for similar forms, it increases 
productivity by saving time which would have been spent setting up the form layout.    If you
use a common set of layouts for everyone it also helps staff to adhere to any "house style" 
you may want to standardise on.



Applying An Existing Layout To A Form

You can apply an existing layout to a form at any time either before you create the body of 
the form or after you have typed in all or part of it.

Choose Apply Saved Layout from the Layout menu and you will be presented with a list of all
the saved form layouts to choose from.    Choose the layout you want and press OK and the 
new layout will replace any existing one.    This will change all the settings on the layout 
menu to those in the new layout.



Changing An Existing Layout

To alter a layout first open a New Window, then apply the layout you want to change to the 
empty form on the screen by selecting Apply Saved Layout from the Layout menu.

All the settings on the Layout menu will now be copied from the saved layout.

Make the changes you need to make to the layout by selecting the appropriate commands 
from the Layout menu.

When you have finished use the Save Layout command on the Layout menu to save the 
changes in your layout.



Basing A New Layout On An Existing Layout

If the layout has been saved using the Save Layout command then to retrieve the existing 
layout first open a New Window, then apply the layout you want to change to the empty 
form on the screen by selecting Apply Saved Layout from the Layout menu.
Alternatively, if the layout is included in an existing form but not saved separately as a 
layout then open the existing form using the Open command from the Files menu.

All the settings on the Layout menu will now be copied from the existing layout.

Make the changes you need to make to the layout to turn it into your new layout by 
selecting the appropriate commands from the Layout menu.

When you have finished use the Save Layout command on the Layout menu to save the 
changes in your layout, remembering to use a new name for the layout, if you began by 
retrieving a layout with Apply Saved Layout.

If you opened an existing form to retrieve the layout do NOT save the form now unless you 
want the changes you have made to the layout to be included in that form too.



The Default Layout

There is a special layout called DEFAULT.    This layout is special in that all new windows 
opened in the forms designer will automatically have that layout.    In other words the default
layout holds the default settings for forms design.

You can change the default layout by following the instructions under Changing An Existing 
Layout given above.



Choosing The Printer And Printer Paper Bins

The Print Routing command on the Layout menu allows you to set which printer you want to 
use, if you have more than one and also which paper bin to use if your printer has more than
one paper bin.

Print Routing is particularly useful in a networked environment, where you may have more 
than one printer.    You can route a document to a particular printer, this specifies that 
whenever that document is printed it will always be sent to this printer irrespective of the 
Windows Default Printer.

If you route a document to the Windows Default Printer it will go to whichever default printer
you have set in Windows using the Printer Setup command on the File menu.

Printer Choose your printer from the list.    The list of printers shown is those 
printers you have installed in Windows so if you don't see your printer on the list you 
need to refer to your Windows documentation for instructions on how to install your 
printer in Windows.

Paper Bins Select the bin you want to use from the list of bins for each section of 
the form.    If your bins are not all shown on the list then it is because your printer is not 
fully installed in Windows.    Again you need to refer to your Windows documentation for 
instructions on how to adjust the installation of your printer in Windows.    The Setup 
button allows you to get into Windows Printer Setup for this printer, without leaving 
forms design.

Print Field Contents Only If you check this then only the contents on the fields will 
be printed when you fill in the form with form entry or print out a database record on the 
form from the database.    This is to allow you to use the database and form entry easily 
in conjunction with your own pre-printed forms.



Previewing And Printing Blank Forms
Previewing The Form
Printing The Form

You can print all pages of a form or a specified range of pages only.    You can also preview 
the printed pages, in which case you see on the screen a miniature "picture" of each page 
that will be printed which reflects the choices you have made for margins and gives an idea 
of how the form will look when printed.



Previewing The Form

Select the Print Preview command from the File menu and the preview screen will appear, 
showing you a preview which includes the current page.

>> / << will move forward or backwards a page at a time as will PgDn and 
PgUp.

Single Page / Double Page controls whether you see one page or two pages on the 
screen at a time.    Double page is illustrated here.

Thumbnail will show a medium size picture of around 6 pages at a time.

Fingernail will show many tiny pages on the screen at once.    It is excellent for 
getting an overview of a form with several pages.

Print causes the print menu to appear, as described below under Printing The Form.

Close clears the preview from the screen and returns to working on the spreadsheet.

Go To chooses a specific page number.





Printing The Form

When you want to print the form choose the Print command from the File menu and the 
following dialog box will appear:-

NOTE: If you want to print the form with some or all of the fields filled in then you can print 
it from Forms Entry, which will allow you to fill in the fields before printing.    If you have 
linked the form to a database you can also print it from the Database with the fields filled in 
with information taken from database record(s).

The form will always be printed on the printer to which it has been routed using Print 
Routing.    This may be the Windows Default Printer in which case you can change the printer
using the Printer Setup command on the File menu before printing.



Form Entry

Selecting A Form
Filling In A Form
Inserting Standard Phrases
Capturing Information From A Database
Saving A Filled Form
Cancelling Or Clearing A Form
Previewing Completed Forms
Printing A Form

The form entry application allows you to fill in a form on the screen and print the completed 
form.    The form you are filling in may be a pre-printed form or the complete filled in form 
can be printed onto blank sheets of paper.

Optionally you can also save the contents of the form as a contents file, which you can 
reopen later.



Selecting A Form

When you start the form entry application you will be asked which form you would like to 
open and fill in.    Choose the form you want from the list of forms displayed.      Note: see the 
general description of working with disk files, which explains the Drives, Directory and paths 
or folders.    

Library If you want to fill in one of the forms from the TopLevel forms library press the 
Library button (Win 3.x) or click the Library folder (Win 95) to see a list of forms in the library
and select one of these.

Filled Forms If you want to reopen a previously filled form (which you saved with the Save 
Contents command in the Form Entry application), rather than opening a blank form then 
press the filled forms button (Win 3.x or use Files of Type to view the "contents" files.

You will find that there are Save Contents and Save Contents As commands on the File 
menu.    These can be used to save the complete filled form.    

When you have finished filling in a form you print it.    After this you can either fill in another 
copy of the same form for printing, use the Open command on the File menu to open a 
different form to fill in, or use the Close command on the File menu to close the window 
altogether and move on to one of the other applications.



Filling In A Form

Skipping Past Fields

Initially the cursor will be placed in the first character of the first field.    The following 
movement and deletion keys can be used:-

Move within the field  
Move from field to field  Enter and Shift 
Skip forward    / 
backward past a group 
of identical fields

Shift PgDn and
 Shift PgUp    *see note

Delete character Del and 
Move to start of next 
line in a multi line field
Move down or up a 
screen

PgDn    PgUp

Move down or up a 
page

Ctrl Pg Dn and Ctrl 
PgUp

Go to any page Go To function button

* NOTE: For skipping to work at all the form must have been designed to include "Mark For 
Skip" fields as described under Specifying The field Input Order.

You can also use the mouse to move around clicking the left mouse button to put the cursor 
into one of the fields.    The scroll bars can be used to move to a new position in the form.

During filling the form will appear as shown below on the screen.



Can't Move To A Field?

The field may have been drawn as a box during forms design.    This prohibits it from being 
filled in on the computer, leaving it for manual completion later.    

If the field should be filled in on the computer then go back to the forms design application 
and alter the form so that there is a field in this position on the form.



Skipping Past Fields

If you have a group of identical fields to fill in, such as lines on a commission report or 
purchase order you will want to skip out of the last line you are using onto fill in information 
beneath the body of the purchase order.
You can scroll quickly to any position on the form using the mouse and vertical scroll bar, but
where touch typists are involved this is slow because it requires them to take their hands 
away from the keyboard.

Tabbing through all the blank fields on a form with the keyboard is even slower so two 
keystrokes are provided:-

Shift PgDn skips on bypassing some following fields

Shift PgUp skips back, bypassing some preceding fields

NOTE The design of the form must have been set up so that some of the fields are defined 
as "Mark For Skip" in the Field Filling Order for this feature to work.



Inserting Standard Phrases

You can set up a standard phrase library as described under Creating Standard Phrases, for 
use when filling in forms.    You can then insert the phrase during form filling either by pulling
down the Insert menu and choosing Phrase    so that you can select the phrase by name or 
by using the keystroke shortcut which was chosen for the phrase.



Capturing Information From A Database

Often when you are filling in a form you will want to include information taken from a 
database record, typically a contact name and address on the form.    For example, a fax 
form can be used in this way - the name, address and fax number at the top is captured 
from a contact database and then the fax message is filled in and printed at the bottom.

Provided that the fields on the form have been named to match the database items; then 
you can capture a name and address from a database in only a few keystrokes. When you 
design the form you can easily set up the field names correctly by linking the form to the 
database from the form designer, then linking the individual fields which are to be captured 
to the corresponding database item      This is described separately in the chapter on the 
form design application.

Note that you need to already have the database of contacts open in    a Form Data window, 
so prior to your first capture please make sure the relevant database is Open.

1 Open the form to fill in as normal.

2 Pull down Insert and choose From Database, or press the Capture button on the button 
bar.

3 The list of records in the current database will be presented.
4 Select the record you want and press Paste.    Details will be captured onto the screen 

form and the screen form will be presented ready for you to fill in further details.



When the list of database records is presented there are various facilities available on 
buttons above the record list are:-

Order Display the list in a different order.    You will be offered the choice of any of 
the database indices as when using the database.

Go To Go instantly to the specified record again using any of the database indices.

Filter Filtering is a useful search aid.    Use a filter so that only those records 
matching the filter are displayed.    Filters available include named selections associated 
with this database and logs.    They work as they do when using the database.

View Change the view on the database to a different list layout.    Select from the 
defined list layouts for this database.

DatabasePresents a list of open databases similar to the picture below (which contains 
only one database called import).    Use this to search different contact databases.





Saving A Filled Form

Once the form has been filled in you may want to save it in the computer.

Save Contents This will prompt you for a name for the form contents, then save those 
contents under that name.    You can reopen them later from File Open.

Save Contents As This saves a copy of the contents with a different name.

When you save the contents the form itself is not saved again with the contents.    Instead 
the system remembers which form to use with these contents.    So, if you change the design
of a form after saving contents, next time you open the contents the design will 
automatically be updated for you.



Cancelling Or Clearing A Form

Once the form is printed and/or its contents are saved you will want to clear the field 
contents ready to fill in the next copy of the form.    Press the Clear function button or select 
the Clear command from the Edit menu.

If you are part way through filling in a form and want to clear it without printing then again 
you should press the Clear function button or select the Clear command from the Edit menu. 
You will be prompted to confirm that you want to throw away the current form contents 
without printing them.



Previewing Completed Forms

You may like to preview the form before printing it, just to ensure that you have completed 
everything you need.    Press Preview and the current page will be previewed as shown 
above.

You can move from page to page using PgUp and PgDn or Go To and use single page, double 
page, thumbnail or fingernail sized previews as described for forms design.

When you have finished previewing either go straight to printing by pressing the Print 
button, otherwise press Cancel to continue filling in the form.



Printing A Form

Printer Setup

Select the Print command either via the Print command on the File menu or using the Print 
button on the form entry or preview screens and the Print dialog will appear:-

Print Field Contents Only Check this and only the fields you have filled in will be 
printed.    The form itself will not be printed.    This is useful for working with pre-printed 
forms.

Options Allows you to choose the picture resolution.    Pictures can be printed as 
outlines, which is useful for fast draft printing.



Printer Setup
The form may have been routed to always print on a particular printer when it was designed.
In this case it will automatically be printed on the printer to which it has been routed.    
Alternatively the routing may be set to the Windows default printer.    For forms which are 
routed to the Windows default printer then you can change the default printer using File 
Printer Setup, prior to using the print command and the form will always be printed on the 
current Windows default printer.



Form Data

New Database Wizard
Finishing Work On A Database
How Duplicates Detection Works
Linking Forms To The Database
Creating List Layouts
Creating Label Layouts
Indices - Viewing Your Records In Order
Selections Of Records
Opening The Database
Adding and Updating Records
Moving Around The Records
Altering The Current Record Order
Deleting Records
Filtering To Work With A Selection Of Records
Finding Suspected Duplicate Records
Searching A Database
Using List And Form Views
Printing The Current Record On A Form
Merge Printing A Batch Of Forms
Printing A Report
Printing Mailing Labels
Choosing The Printer - Print Routing
Mailing Log
Random Sampling For Mailings
Importing Comma Separated Data
Database Maintenance

The database allows you to maintain computerised lists.    The list    is usually a mailing list of
some sort containing contact names and addresses.    For example a customer list, supplier 
list or prospect list.    But FastForms database is not limited to mailing lists; for example, it 
could also be used to keep a list of stock items with their costs, shelf lives, delivery lead 
times and usual reorder quantities or to keep a list of company cars with their registration 
number, make, model, cost price, purchase date, planned disposal date and total repair 
costs to date.



New Database Wizard

Select File New from the TopLevel menu and you will be asked to give the name of the 
database and offered the option of basing your database on an existing database or making 
a new one from scratch.    If you choose to make a new one the Wizard will ask you to choose
some fields:-

Press Next to go to Step 3:-

Name This is a meaningful name identifying what should be stored in this item.    
FastForms will generate a form to use with your database automatically.    This default 
form has each item on separate lines with the name of the item shown by its top line.    
The default form can be used to fill in records on the screen and to print out records.
    



Type Select the type from the choices list.    Each item can be one of many types 
including:-

Text can contain letters and numbers of any length.

Numeric either number, comma (i.e. a number with commas) and currency.

Dates is a date displayed in the format indicated. 

Picture contains a picture.

Length is only set for text and numeric types since it is implicit    for dates and 
pictures.    For text the maximum is 500 characters.    For numeric the maximum is 12.10 
indicating the number of digits before and after the decimal point.    For example:-

Length Sample

2 19
2.2 19.34
5.1 12876.5
1.4 1.3456

Value This is the initial or default value which will be assigned to the item.

Duplicates Detection If you select the check box for duplicates detection this will be 
one of the items used to monitor for duplicates.    You can check up to 3 items in any one 
database for duplicates detection.    There is more about duplicates detection under How 
Duplicates Detection Works.

Auto Inc. This only applies to numeric types.    If set the item will automatically increase 
by 1 for each new record added to the list.    It is especially useful for invoice numbers.    
Put the starting value in Value.

Once you have set up the data items FastForms will automatically generate a default form to
go with your database so you can start using it straight away.



Finishing Work On A Database

You will notice that there is no Save or Save As command on the File menu in the database.   
This is because your work on a database is automatically saved as you work.    Nevertheless 
it is important to use the Close command on the File menu and to Exit from the TopLevel 
menu properly before you switch off your PC when using the database.    If you just switch off
whilst in the middle of working on a database this could damage your database, particularly 
the index files.    



How Duplicates Detection Works

The object of duplicates detection is to warn you if you try to add a record which is already 
present on the database.    Typically this might be useful in a situation where the database 
was being used to maintain a list    of sales enquiries.    

Duplicates detection checking is performed extremely fast, in fact FastForms maintains a 
special index of all records so that it can quickly scan for possible duplicates.

Duplicates detection is only carried out if you have flagged some items to be used for it 
when setting up the database.    You can flag up to three items to be used for this purpose.    

It is most likely that you will want the company name and the town as items for duplicates 
detection so we will suppose that these two items have been flagged for duplicates 
detection.    
FastForms is clever enough to notice if the company names are similar but not identical 
because it examines the first significant word of each item to see if they are the same.    
Words like "A" and "The" are ignored and it makes no difference whether a word is in 
capitals or lowercase.    

Consider the following example records:- 

Dellafield Print
Stroud

The Dellafield Print Shop
Stroud, Glos

Dellafield Ltd
Stroud, GL5 3DT

All these would be detected as possible duplicates of each other.
Since we have chosen duplicates detection on the company name and town only then two 
enquirers from the same company would also be identified as possible duplicates.    This will 
probably be useful even if you don't actually delete the second enquirer.    

However if you don't want two enquirers from the same company to be identified as possible
duplicates you can set up the name item as the third one to be used for duplicates 
detection.    Since all three items must "match" for records to be possible duplicates two 
enquirers from the same company will then no longer be reported as possible duplicates.

When duplicates detection is in use you are warned when you add a record if it has possible 
duplicates.    You can also scan the database examining possible duplicates for any record 
and deleting or altering them.



Linking Forms To The Database

Choose Link Form from the Tools menu and a Wizard will guide you through the linking 
process.

After choosing your form the Wizard prompts you to show which form field is to be used for 
each data item:

When you press Finish your data is displayed on the new form.



Creating List Layouts

Step 1 - Naming The List
Step 2 - Setting Up Items And Item Headers
Step 3 - Sort Order
Step 4 - Totals
Step 5 - Print Routing
Step 6 - Margins
Step 7 - Selection

You can create reports which list off the records on the database.    There is an illustration of 
a typical report pictured below.

You may also want to view your records on screen in a list rather than one at a time on a 
form. 

You can have several different list layouts for one database so each layout is given a name. 
In the list layout    you decide what is to appear on each report, including which items are to 
appear from each record, what the page header will be, what the column headers will be.    
For printed reports you can also have the report always sorted in a particular order, have the
report list only certain records rather than all records on the database, and have totals 
printed for the numeric fields.

                                  Customer List In Account Code Order

Account Customer Date of Turnover
Code Name First OrderLast Year

ABBA Automotive Business Ltd 10/12/90 £150,500
ARL1 Andy's Repairs 19/01/89 £12,002
BAW1 British Autos 12/05/91 £98,435
BST1 Belgian Supercars 22/01/85 £97,865
DEQ1 Dave's Engine Shop 23/06/90 £13,400
EEF1 Enfield Engines 12/12/81 £46,705
ERL1 Ealing Reflectors 10/01/55 £14,750
FAT1 Fat Larry's Spares 12/12/91 £34,780
GCC1 Gary's Collector Cars 01/03/56 £142,560



Step 1 - Naming The List

Choose Lists & Reports from the Tools menu and either give a new name, or select an 
existing list by name to edit.



Step 2 - Setting Up Items And Item Headers

Page Header The Page Header is printed at the top of every page.    It has up to 
three parts which will be printed together on one line.    The three parts are printed left 
aligned, centred and right aligned respectively e.g.:-

M.M. Holdings Ltd Current Share holdings Year Ended Sep '92

There are four special words you can include in the page header, all beginning with an @
sign:-

@pageno prints the page number.

@filename prints the file name.

@longdate prints today's date in long format, e.g. 27th January 1992.

@shortdate prints today's date in short form, e.g. 27/01/92.

Item Header 1 / 2 These are the two line column headers that you want to above 
each column of items on every page.

Items Drop down the list to select the name of the required data item.    

Widths This is the width to allow for each column of items on the list.    FastForms will 
put in a suggested width for you based on the widths of the items and their headers.    
The total report width is also shown so that you can see how close you are to filling the 
width of the paper.

You can adjust a column's width either by dragging the divides between the column 



numbers above the items or by pressing the Set Width button.

Max. Lines Per Row This is the maximum number of lines each record is to be 
allowed to take up on the screen (only one is allowed on printing).

Insert/Delete will insert/delete a column

Appearance sets the typeface, point size and character style separately for the page 
header, item headers and items.



Step 3 - Sort Order

You can specify a sort order in the list layout, in which case the report will always be printed 
in that order.    If you don't specify a sort order here then you will be given the option to 
produce the report in the order of any of the indices each time you print it. 

(Note: indices apply to the database as a whole not just to the reports and are described 
separately under Indices- Viewing Your Records In Order.)

Press the Sort Order button and the following dialog box will appear:-

Item 1 / 2 / 3 / 4You can specify up to 4 of the data items you are keeping on each 
record to be used to control the report order.    Item 1 is the overall or most significant 
order and item 4 is the least significant order.    For example the illustration above shows 
item 1 as the town and item 2 as the company name.    This report will list every 
company on the database ordered so that the towns are presented in alphabetical order. 
Within each town the companies will be listed alphabetically. 

Break On Change This is used in conjunction with the Totals button.    When you 
scheck Break On Change you are specifying that you want totals when this item 
changes.    Which items are totalled at the break is specified using the Totals command.    
In this example we have checked this option for item 1 the town.    So, provided we have 
used the Totals command to specify which items to print totals for the report could look 
something like this:-



                                                                      Customer List By Town

Town Customer Date of Turnover
Name First OrderLast Year

Alford Automotive Business Ltd 10/12/90 £150,500
Alford Andy's Repairs 19/01/89 £12,002
Alford British Autos 12/05/91 £98,435
Alford Belgian Supercars 22/01/85 £97,865
Alford Dave's Engine Shop 23/06/90 £13,400
Alford Enfield Engines 12/12/81 £46,705
Alford Ealing Reflectors 10/01/55 £14,750
Alford Fat Larry's Spares 12/12/91 £34,780
Alford Gary's Collector Cars 01/03/56 £142,560

-------------
 £610,997
-------------

Bristol Anglo Motors 12/01/90 £15,700
Bristol Devon Speedstars 14/10/80 £170,700
Bristol Jenny's Jeeps 19/09/91 £120,350
Bristol Redbridge Roadhogs 21/03/91 £115,734

-------------
 £422,484
-------------



Step 4 - Totals

Totals can be printed for up to four of the items in the list layout. 

Item 1 / 2 / 3 / 4Choose the items from the list layout that you want to be totalled.

Totals At Control Breaks This works in conjunction with the sort order which was 
described directly above.      For our report we need to check this box so that Turnover 
totals are printed at control breaks.    So totals for the Turnover item appear for each 
Town.

Totals At Report End Check this box to get a grand total for the item at the end of 
the report.

Totals At Page End This allows you to have a total printed at the bottom of 
each page which is either a total for all records on that page or a running total of all 
records printed so far.

 



Step 5 - Print Routing

Press the Print Routing button to choose the printer and printer paper bins you would like to 
use for your report.

Target Printer Choose your printer from the list.    The list of printers shown is those 
printers you have installed in Windows so if you don't see your printer on the list you 
need to refer to your Windows documentation for instructions on how to install your 
printer in Windows.

Use Windows Default Printer Check this to allow the operator to select the 
printer just before printing the report using the Printer Setup command on the File menu.

Paper Bins Select the bin you want to use from the list of bins.    If your bins are 
not all shown on the list then it is because your printer is not fully installed in Windows.    
Again you need to refer to your Windows documentation for instructions on how to adjust
the installation of your printer in Windows.        The Setup button allows you to get into 
Windows Printer Setup without leaving the database list layout.



Step 6 - Margins

Press the Margins button to set up details of the stationery and margins to be used for 
printing the report.



Step 7 - Selection

You may want the report to list all records on the database or only a selection of records e.g.
only list customers who spent over 50,000 with you last year.    If you choose a selection to 
apply to the report here then you are making that selection part of the list layout.    When 
the report is printed it will always be for the same selection of records.

If you have defined a list layout which you want to be able to use to print reports with 
several different selections do not choose any of the selections here in the list layout.

NOTE Any selection of records you want to use with your report must be already 
set up and given a name as described under Selections Of Records.    This allows you 
to use the same selection for several purposes e.g. for printing labels and for printing
reports, without having to set up the same selection rules several times over.

Press the Selection button and choose the selection you want from the list.



Creating Label Layouts

Step 1 - Naming The Label Layout
Step 2 - Choosing Items To Appear On The Labels
Step 3 - Editing Label Lines
Step 4 - Gallery of Label Stationery
Step 5 - Custom Label Stationery
Step 6 - Print Routing
Step 7 - Appearance

Before you can print labels you need to define one or more label layouts.    The label layout 
tells FastForms the size and arrangement of labels on the label stationery and also what 
items from the database you would like printed on each line on the label.

Once you have set up a label layout it is remmbered for next time.    In fact you can set up 
several different label layouts, choosing the name you want to use for each one in the 
future.



Step 1 - Naming The Label Layout

Choose Labels from the Tools menu and either give a new name, or select an existing label 
layout by name to edit.



Step 2 - Choosing Items To Appear On The 
Labels

Label Contents Initially all the lines are blank and the top line is selected ready for you
to start filling in contents. Move up and down over the lines in the box    pressing the Edit 
button to select their contents.

Insert / Delete Insert or deletes a line from the label.



Step 3 - Editing Label Lines

Press Edit on each line to use the Label Line dialog box to set it up.

Item 1/2/3/4/5 Each line can contain up to 5 items from the database.    Pull down the 
list of items on this database for each item you require and select it by name.    Here the 
first line of a name and address label has been set up.

Multi Line Items If you want to include an item which will occupy several lines on
the label then this must be the only item on the line.      This is useful if you have put an 
address into a single item on the database. 

Maximum Lines To Occupy This is the number of lines on the label you want 
to allow for this item.

Wrap/Truncate If you have a free format notes item, containing a whole 
paragraph, then you will most likely have typed this in on the screen using 
automatic word-wrap, rather than pressing  at the end of each line.    In this 
case you should choose Wrap here too.

On the other hand if you have an address item you have probably pressed  at the end of 
each line.    In this case you will most likely want to choose Truncate so that any line of the 
address which is too long to fit on one line of the label is truncated, not wrapped onto the 
next line.



Step 4 - Gallery of Label Stationery

Press Gallery to select the label stationery in use:-

Press the button which corresponds to your label stationery.



Step 5 - Custom Label Stationery

Click Customise only if you have label stationery which is not in the gallery.

Measure the distances and enter the values in inches or centimetres depending on the 
system settings.



Step 6 - Print Routing

Press the Print Routing button to choose the printer and printer paper bins you would like to 
use for your report.

Target Printer Choose your printer from the list.    The list of printers shown is those 
printers you have installed in Windows so if you don't see your printer on the list you 
need to refer to your Windows documentation for instructions on how to install your 
printer in Windows.

Use Windows Default Printer Check this if you want to be able to swap the 
printer using the Print Setup command on the File menu just before you print.

Paper Bins Select the bin you want to use from the list of bins for each section of 
the document.    If your bins are not all shown on the list then it is because your printer is
not fully installed in Windows.    Again you need to refer to your Windows documentation 
for instructions on how to adjust the installation of your printer in Windows.        The Setup
button allows you to get into Windows Printer Setup without leaving the database list 
layout.



Step 7 - Appearance

The Appearance dialog box allows you to set the font and style of text on the labels.



Indices - Viewing Your Records In Order

When you are working on the database it may not be adequate simply to see the records in 
the order in which you typed them onto the database.    You may want to be able to see the 
records in several different orders and also to print    in these same orders.    

The chief benefit of an index is that you can use it to move quickly to the required record on 
the screen.    You can also get reports printed in the order of one of the indices, although it is 
also possible to get reports printed in other orders as explained under Creating List layouts.

Select Tools Database Record Ordering:-

The first index you define should be the one which will be used most often since it is this one
which will be in use when you first open a database.



Selections Of Records

Range Check
Comparison Check
Complex Selections

It is often useful to be able to work with only a selection of records.    Once you have made a 
selection FastForms will remember it for future use.    So that more than one selection can be
remembered you give each selection a name by which to recall it in the future.

See Using A Filter To Work With A Selection Of Records, Creating List layouts and the 
sections on Printing for details of how you can make use of the selections once they are set 
up.

Choose Tools Selections and give the name for your selection.

This is a selection of all records which have a comment on them relating to a recent 
exhibition for companies between A and M.    This is a simple selection in that it does not 
involve other selections.    As you can see from the illustration it is possible to set up 
complex selections, which use conditions set up in other selections.    The simple selection 
shown here involves two conditions, a comparison on Comment-1 and a range check on the 
company name, both of which must be true for a record to be included in the selection.

And / Or Either all the conditions you give must be true for a record to be included in 
the selection or any of the conditions can be true.    Notice that the word "And" has 
appeared between the two conditions in the illustration to confirm the choice here.

Edit Allows you to alter an existing condition.

Delete Deletes one of the existing conditions.

Add Range Adds a condition which checks an item is between two values. 

Add Comparison Adds a condition which compares an item with a value or 



another item.

Add Selection Adds a condition which is another selection, making this a complex 
selection.    You will be offered the list of selection names to choose from.



Range Check

When you select range check a dialog box similar to this appears.

In this picture Company is being checked to ensure that it is between A and M.



Comparison Check

When you select a comparison check a dialog box similar to this appears:-

This is comparing Comment-1 to see if it contains "exhibition".



Complex Selections

Putting a selection within a selection is useful because it allows you to mix "Ands" and 
"Ors".For example two separate selections called A and B could be combined like this to 
make a third complex selction:-

Selection A:- Selection B:-
Age less than 18 and Sex = F OR Weight < 62

chooses all under 18's who are female and all people of either sex and any age who weigh 
under 62 Kg.    18 and overs can be included as long as they weigh below 62Kg.

This is not the same as the selection combination:-

SelectionA:- Selection B:-
Age less than 18 AND Sex = F or Weight < 62

which chooses only under 18s who are either female or weigh under 62Kg.    18and overs are
never included.

Complex selections are a very powerful tool and many will find they never need them.    If 
you find them difficult to grasp then you may find it useful to create some dummy records 
which should and should not be included in the selection and use these to test that the 
selection is actually working properly.



Opening The Database

Select the Form Data icon on the TopLevel menu and use File Open to open an existing 
database.



Adding and Updating Records

Add Click the Add function button to get a blank form in which to add new records.

Update Click Update to stop adding new records and start browsing existing ones.

Finishing The Add or Update Press the Ctrl  or Ctrl 
 key combination when you have finished altering the record.

Keys You Can Use When Filling In The Record Form

Move within the field  

Move from field to field  Enter and 
Shift 

Skip forward    / backward 
past a group of identical 
fields

Shift PgDn and
 Shift PgUp    *see 
note

Move to start of next line in 
a multi line field

Delete character Del and 

Move down or up a screen PgDn    PgUp

Move down or up a page Ctrl Pg Dn and Ctrl
PgUp

Move between records and 
finish entering record

Ctrl  or Ctrl 

Go to any page Go To function 
button

* NOTE: For skipping to work at all the form must have been designed to include "Mark For 
Skip" fields as described under Specifying The Field Input Order.    There is no skipping in the 
automatically generated screen form.

You can also use the mouse to move around clicking the left mouse button to put the cursor 
into one of the fields.    The scroll bars can be used to move to a new position in the form.

Multi-Line Fields If you have a "Notes" field on your form it may well extend over 
several lines. There is no need to press the  or Enter key at the end of each line, since you
always have automatic word wrap between the lines just as you do in the word processor.    
You can however use the 

 or Enter key to start the next line before the current line is full.



Moving Around The Records

When you are not adding new records you can move from record to record examining 
records, altering them and printing them

To Move To The Next/Previous Record Press the Ctrl  key combination and the next 
record will be displayed.    Similarly pressing Ctrl 

 moves to the previous record.    This will be the next/previous record in the order shown on
the top left.      See Altering The Current Record Order below for how to alter the current 
index.

To Go Straight To Any Record Press the Go To function button

.... to Go To This is what you want to search for.    FastForms will display the first 
record after the one you give if it cannot find an exact match.    So if you want to go to 
the first record containing a surname beginning with B just put B in here.

Index This is the name of the index you wish to use, e.g. if you want to go to a 
record containing a particular surname then you need to use the surname index.    You 
can also go to a record by its record number.    If the index you want to use is not 
currently selected then select it before filling in the Go To field.



Altering The Current Record Order

When you move through the records and probably also when you print some of the reports 
the order is determined by the current index.    You decide which indices you want to be 
available when you set up the database layout.

Press the Order button on the status bar (key combination Ctrl O) to choose which of the 
available indices you want to use.    A dialog box will be displayed at the top of the screen as 
shown in the illustration.    Select the index you want.    Record Number order is just the order
in which you typed the records onto the database.    



Deleting Records

You can delete a single record or automatically delete a whole group of records.    The beauty
of FastForms is that deleted records are not lost for ever.    This is because they are not 
physically removed from the database instead FastForms just marks them as deleted.    The 
effect of this is the same as if they had been deleted, they do not appear on the screen or 
on reports and other printouts.    But they can be retrieved at any time prior to the next 
database squash.

Retrieving deleted records is described under Database Maintenance.

Single Record Deleting a record is simply a matter of pressing the Delete function 
button when the record is displayed.    You will be prompted to confirm that you really want 
to delete the record, and provided that you do the next record will then be displayed.

Selection of Records You can delete all the records on any filter, i.e. all the records in
any selection or all the records on one of the logs or all the records which are a suspected 
duplicate of one of the other records.    This is a very powerful option so we recommend that 
before you do it you examine some or all of the records you intend to delete to check that 
they really are the records you are expecting.

To delete the records first press the Filter button on the status bar and select the group of 
records you want to delete as described under Using A Filter To Work With A Selection Of 
Records.

Once the filter is active you will see its name displayed next to the Filter button and only 
records which match that filter will be displayed as you page through the database.

When you are satisfied that you have selected the right filter call the Edit menu and choose 
the Delete Filtered Records command.    This will delete all records in the filter.



Filtering To Work With A Selection Of Records
A filter enables you to work with only a small part of the database.      Filtering affects which 
records you see on the screen. Any of the selections defined in the database layout can be 
used as a filter.    

Filtering does not affect reports, but you can use the same selection to control which records
appear on a report as you are using for filtering.

Press the Filter button on the status bar and you will be prompted to make your choice of a 
selection, a log or a set of suspected duplicates of the currently displayed record or to switch
filtering off altogether:-

In this illustration one of the selections is being chosen.    When you have chosen the filter 
you want the screen will change to display only records on the database that match this 
filter.

Notice that you can tell from the indicator next to the Filter button on the status line which 
filter is actually active.    So, if you cannot find a record which you are sure you typed onto 
the database, be sure to check that filtering is not preventing the record from showing up.

To Stop Filtering Press the Filter button again and select No Filtering.



Finding Suspected Duplicate Records

To Find Suspected Duplicates

Provided that your database layout has been set up to monitor for possible duplicates 
FastForms will warn you when you add a new record if there are suspected duplicates of this 
record on file.    You may yourself suspect that a record is a duplicate either before you add it
or whilst you are examining the database.    FastForms helps you to keep your database free 
of duplicates by allowing you to examine the suspected duplicates of a record.    You can 
delete or alter the record or any of its suspected duplicates as you examine them.

Examining duplicates works like filtering which is described above under Using A Filter To 
Work With A Selection Of Records.



To Find Suspected Duplicates

Bring the record whose duplicates you want to see onto the screen and press the Filter 
button.    You will be prompted with a list of all the filters available including the special 
duplicates filter as illustrated:-

NOTE If you cannot select the duplicates filter from here it is because your database layout 
has not been designed to monitor for duplicates.    You, or the system supervisor, need to 
adjust the layout so that duplicates monitoring is performed.

Select the duplicates filter and now when you move through the records only suspected 
duplicates of the current record will appear on the screen.    Move through the records, 
deleting or altering records as necessary to remove unwanted duplication.

To Stop Filtering Suspected Duplicates Press the Filter button again and select No
Filtering or a log or selection for the filter.    Note that if you alter or delete the original record
this may alter or put an end to duplicates filtering automatically because there may be 
different duplicates or no duplicates at all.



Searching A Database

Choose Edit Search and you will be prompted to enter the comparison:-

Only records which match this comparison will be displayed as you page through the 
database.    Use the Cancel button on the Status bar when you want to stop searching.



Using List And Form Views

Pull down the View menu to choose any of the linked forms or any of the lists you have set 
up.

List view is great when you want to see several records at once.



Printing The Current Record On A Form

FastForms has been designed to make it very easy for you to print off a single standard form
addressed to one of the people on the database. When you are working on the database 
there is always a Print button available.    Whenever you press the Print button the currently 
displayed record will be printed using the currently selected form.

Start Page / End Page Use these to print only part of a mult-page form.

Copies Use this if you need more than one copy of the same record.

Options Sets the picture resolution, choose outline for fast draft printing of pictures.

Print Field Contents Only Check this to suppress printing of the form itself.    This is
useful if you have pre-printed form stationery.



Merge Printing A Batch Of Forms

When you    click Merge Print, instead of just printing the current record you can print a 
whole batch of records. 

Selection and Print Order Choose from the drop down lists.

Log Name If you want to log the mailing give it a name here.    Logging the 
mailing means that FastForms will remember which records were printed.    You can then 
use this to explicitly include or exclude them from future mailings.    See Mailings for a 
fuller explanation of this.

Count Before you print the mail shot you may like to see how long it will be.    Press 
this button and a count of the records will be displayed on the screen.

Print Press Print when you are ready to print the mail shot.

Options This brings up the same questions already described for priniting individual 
records and some further ones related to mailings.    See Mailings below for a fuller 
description.



Printing A Report

Click the report function button.    You will be asked which list to print.

When you have chosen your report a further dialog box appears.        It shows which report 
will print and also on which printer it will appear.

Selection and Print Order Choose these from the drop down lists (Note that these 
are not selectable if you have predetermined them in the list definition).

Count Before you print the report you may like to see how many records it will 
include.    Press this button and a count of the records will be displayed on the screen.

Print Press Print when you are ready to print the report.

Options This brings up further questions related to mailings.    See Mailings below for a 
fuller description.



Printing Mailing Labels

Select the Labels function button or choose the Labels command from the File menu and 
choose the label layout you want.

When you have selected the label layout you want to use a dialog box similar to the 
following will appear:-

Selection and Print Order Choose these from the drop down lists (Note that these 
are not selectable if you have predetermined them in the label layout).

Log Name If you want to log the mailing give it a name here.    Logging the 
mailing means that FastForms will remember which records were printed.    You can then 
use this to explicitly include or exclude them from future mailings.    See Mailings for a 
fuller explanation of this.

Current Record Only This prints a single label for the currently displayed record.

Count Before you print the labels you may like to see how many there are.    Press 
this button and a count of the records will be displayed on the screen.

Print Press Print when you are ready to print the labels.

Options This brings up further questions mainly related to mailings.    See Mailings 
below for a fuller description.



Choosing The Printer - Print Routing

Forms, reports and labels may have been routed to a set printer or they may be routed to 
the Windows Default Printer.    

If they are routed to the default printer you can set a different printer using the Printer Setup
command on the File menu before you print.

If they are routed to a fixed printer the Windows Default Printer will be ignored. This is 
particularly useful for printing labels if you have several printers and always keep    labels 
ready on one printer.



Mailing Log

When you print labels or merge print forms FastForms allows you to name the mailing with a
Log Name.    Each named mailing becomes an entry on the mailing log.    So if you do a 
mailing of a special offer once a month you might name your mailings:-

January Offer
February Offer
March Offer
. . .      e.t.c.

Your mailing log then contains these names.    FastForms remembers which records on the 
database received each of the mailings.

You can use the mailing log to select records for mailing again e.g. to send a repeat mailing 
about the January offer to everyone who got the January offer.    You can also print reports 
listing all records in a particular mailing e.g. to get a list of 'phone numbers for follow-up 
calls.

When you are moving through the database you can check which mailings the currently 
displayed record has received.

Creating A Mailing Log Name This can be done whenever you print a mail shot (Merge 
Print)    and also when you print mailing labels.

Restricting Print By Mailing LogYou can restrict a report, a mail shot or a labels print to 
include or exclude only records from a particular mailing log.    (this is an Option on the 
Report, Mailmerge and Labels commands).

Include only records in mailing Choose one of the mailings you have previously 
printed and logged from the list.    Only records which were included in this mailing will 
be included in this print.    This enables you to print off the same recipients as a previous 
mailing.    For example, you might have a report which lists the name, company and 
'phone number of everybody you mailed with a special offer last week.    This report 
could be used to make follow up 'phone calls.

Exclude all records in mailing Choose one of the mailings you have previously 
printed and logged from the list.    Records which were included in this mailing will be 
excluded from this report.    This could be useful if you wanted to exclude a previously 
logged random sample.

NOTE If you use one of these options and you have chosen to limit the report to a 
selection then FastForms will first take the selection then it will include or exclude the 
records from the mailing before it prints the report.

Checking Which Mailings Went To A Record You can do this when you have the record 
displayed on the screen by choosing the View Log Entries command from the Tools menu.

Log DeletionYou can have up to 64 log entries for a database.    After this you need to 
delete some of the log entries.    This is carried out via the Maintenance command on the 
Tools menu.

Also see Random Sampling For Mailings





Random Sampling For Mailings

You can limit a mail shot or a labels print    to a random sample of your chosen percentage 
size.    (again this is an Option on the Merge Print and Labels commands).    This allows you to
test mail a small percentage of records so that you can cost-effectively ascertain whether it 
is worth mailing all the records.    You choose what percentage of records you want to include
in the test mailing and FastForms will choose a random sample of this size for you.        
If you are test mailing a random sample and need to print more than one thing to go with 
each envelope e.g. a form and a label then you must give a mailing log name to the mailing 
when you print the first thing.    This is because the sampling is random so the only way to 
identify the same random sample for a second print is by the mailing log name.

The mailing log can also be used in conjunction with random sampling to ensure that the 
random sample don't receive a second mailing when the main mail shot is printed. When 
you print the test mailing you log records included in the test mailing, for example if you are
testing the effects on response of offering customers a free gift if they take up your offer you
might call this mailing "Test Free Gift".    If the offer of a free gift is a successful inducement 
to the random sample you will later do another mailing which you might call "Free Gift".    
You can specify that all records which were mailed in "Test Free Gift" are to be excluded from
the main "Free Gift" mailing.



Importing Comma Separated Data

Records containing items separated by a tab or comma can be imported.

 

Select the Import Comma Separated Data command from the File menu and you will be 
asked to select your mailing list.    Choose the file which contains the list you want and you 
will be asked to say which data item in this database corresponds with each item on the 
comma separated record.    

Log Name Give a log name here so that you can identify the records you have 
imported easily afterwards on the database.

Separator Within the records the items may be separated using a tab or a 
comma.

Apply Defaults Will set blank items to the initial values set up in the Data Items.

Forms Item Pull down the list of data items next to each comma separated 
item number and select the data item you want it copied to.    The comma separated 
items are numbered starting from 1 for the first item on the record.

You can have several comma separated items combined into one item on your new 
database.    For example you may want to combine several comment items into one data 
item on your new database.    This will happen automatically as the records are imported 
provided you choose the same item on the FastForms database for each of the comment 
items on your comma separated file.    The comma separated items will each be put on a 
separate line in the FastForms item.

When you have finished setting up the items press OK and the import will begin.    You will be
informed of the progress and end result of the import.



Database Maintenance

There are various database maintenance activities which you will only need to carry out 
occasionally.    These include retrieving deleted records, rebuilding database indices, 
reviewing the size of a database and squashing a database to forever remove all deleted 
records.    

Select the Maintenance command from the Tools menu to reach the Maintenance dialog box.

Database Statistics These give you a summary of the database.

Squash Database Press this button if you want all the deleted records and other 
old discarded records to be permanently removed.    This will make your database take 
up less space on the hard disk.

Undelete Records Press this button to recover a record you have accidentally 
deleted.    You will be asked whether to undelete each the record or not.

Rebuild Indices If your PC is accidentally switched off whilst you are working on a 
database, or you accidentally delete the files holding the indices for the database then 
the indices may be missing or corrupted next time you start work on the database.    You 
will know this has happened either because FastForms tells you that the indices are 
invalid or because some of your records are present when you display them in record 
number order but disappear when you display them in index order.

As long as you still have the main records file for the database undamaged you can 
select Rebuild Indices and the indices will be recreated for you.    

If you do manage to corrupt the main records file as well then rebuilding the indices will 
not solve the problem.    In this case it is up to you to restore the database files from your
latest system backup.

View / Delete Logs When you import records onto the database from either TopMail



or a comma separated list and also when you do a mail merge print it is normal to log 
the event.    A log entry is then created with the name you have chosen.    Each record 
affected by the event will then be tagged as belonging with that log entry.

You may want to review the events which you have logged.    In this illustration there are 
only 2 events on the log but there could be up to 64.

You may also want to delete old log entries referring to mailings or imports carried out a 
long time ago.    In any case the maximum number of events on the log is 64 so you will 
eventually need to delete the oldest entries from the log so that you can put new events 
on the log.




